Skip to main content

Important install and upgrade information

This topic contains other pertinent information about the SecureAuth® Identity Platform release 23.07 or later.

Requires upgrade to .NET 6

The upgrade to the Identity Platform 23.07 or later requires .NET 6. SecureAuth Support or Professional Services will work with you on the appropriate updates as part of the upgrade process.

Contact Support to request an upgrade for the Identity Platform and see their KB article about the upgrade process.

SecureAuth Connector update

Identity Platform release 23.07 requires SecureAuth Connector version 2.0.2 or later, for the following features:

  • SecureAuth Connector groups for data store segmentation

  • SecureAuth Connector installer checks for connection with SecureAuth servers

  • Test Credentials button in data store integration settings for Identity Platform cloud deployments

  • Support for "Must change password at next login" in Identity Platform cloud deployments for Active Directory (AD) data stores.

An upgrade to the SecureAuth Identity Platform release 23.07 requires you to reinstall the SecureAuth Connector bundle and change your outbound firewall rule to allow TCP port 5671.

To learn more about the SecureAuth Connector update, see Critical SecureAuth Connector update for SaaS IdP customers.

Requires upgrade to SecureAuth RADIUS 20.12.15

You MUST upgrade to SecureAuth RADIUS 20.12.15 before upgrading to SecureAuth Identity Platform release 23.07.

Older versions of SecureAuth RADIUS will not work with Identity Platform release 23.07.

Contact Support to request an upgrade for the Identity Platform and they will work with you to coordinate your product upgrades.