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SecureAuth Connector troubleshooting

Use this guide to troubleshoot issues with the SecureAuth Connector.

For more information about the latest SecureAuth Connector version, see the SecureAuth compatibility guide.

Note

For important information about SecureAuth cloud infrastructure updates, see Critical SecureAuth Connector update for SaaS IdP customers.

Prerequisites and dependencies

  • Identity Platform release 19.07 or later, cloud deployment

  • At this time, the Connector is not certified for use on the Identity Platform on-premises appliance or a domain controller

  • Recommended installation on a standalone box

  • You must have access to the email address used to provision your Identity Platform account

  • Install or update Microsoft .NET to 4.8.1 or later

  • Access to a local data store server containing your data stores

  • At minimum, the local data store server must have the following system requirements (the same configuration also applies to virtual machines):

Supported operating systems

  • Windows Server 2022 / 2019

  • Windows 11 / 10

Minimum required specifications

For supported browser and platform requirements, see the SecureAuth compatibility guide

  • Microsoft .NET Framework 4.8.1 or later

  • Disk: 200MB

  • RAM: 4GB

Ports to open

Source

Destination / Hostname

Ports

Notes

Connector

Data store

(data store specific)

Common ports:

AD
  • 389

  • 636 (Secure)

SQL
  • 1433

Connector

pkc-4nym6.us-east-1.aws.confluent.cloud

9092

Add this to your firewall allow list

Connector

rabbitmq.secureauth.com

5671

Effective June 5, 2023

Support for AMQP (Advanced Message Queuing Protocol) traffic from the connector to SecureAuth Cloud.

Note

If you have any questions about which ports to open, contact SecureAuth Support.

Symptom

Connector is not responding.

Cause

There are some reasons why the Connector might not be responding:

  • The Windows service is not running.

  • No data stores are configured. The connector is installed but can only send health checks until you add a data store configuration.

Resolution

To resolve connection issues:

  • Restart the SecureAuth Connector service from the Windows Services console.

  • Check the connector logs at C:\ProgramData\SecureAuth Corporation\SecureAuth Connector\logs.