Skip to main content

SecureAuth Connector update

If you have SecureAuth® Identity Platform release 19.07 or later, you should use the latest version of the SecureAuth Connector. Use this guide to check your SecureAuth Connector version and update as necessary.

For more information about the latest SecureAuth Connector version, see the SecureAuth compatibility guide.

Note

For important information about our SecureAuth cloud infrastructure updates, see Critical SecureAuth Connector update for SaaS IdP customers.

Prerequisites and dependencies

  • Identity Platform release 19.07 or later, cloud deployment

  • At this time, the Connector is not certified for use on the Identity Platform on-premises appliance or a domain controller

  • Recommended installation on a standalone box

  • As a system administrator tasked with setting up the Identity Platform for your organization, you must have access to the same email used to provision and authenticate your access to the Identity Platform

  • Be sure to install or update Microsoft .NET to 4.8.1 or later, as this requires a system reboot before you can download and install the Connector

  • Access to a local data store server containing your data stores

  • At minimum, the local data store server must have the following system requirements (the same configuration also applies to virtual machines):

Supported operating systems

  • Windows Server 2022

  • Windows Server 2019

  • Windows Server 2016 (64-bit)

  • Windows 11

  • Windows 10

Minimum required specifications

  • Internet Explorer 11+ or later

  • Microsoft .NET Framework 4.8.1 or later

  • Disk: 200MB

  • RAM: 4GB

Ports to open

Source

Destination / Hostname

Ports

Notes

Connector

Data store

(data store specific)

Common ports:

AD
  • 389

  • 636 (Secure)

SQL
  • 1433

Connector

pkc-4nym6.us-east-1.aws.confluent.cloud

9092

Add this to your firewall allow list

Connector

Allow outbound connection

443

Expires September 1, 2023

Traffic from the connector to SecureAuth Cloud using this port will expire on September 1, 2023

Note

If you install or update the SecureAuth Connector after June 5, 2023, you must change the outbound firewall rule to TCP port 5671 (see the next row below).

Connector

rabbitmq.secureauth.com

5671

Effective June 5, 2023

Support for AMQP (Advanced Message Queuing Protocol) traffic from the connector to SecureAuth Cloud.

Note

If you have any questions about which ports to open, contact SecureAuth Support.

Check for current version of Connector

  1. Go to the directory where the SecureAuth Connector is installed.

    Typically, this is C:\Program Files\SecureAuth Corporation\SecureAuth Connector.

  2. Right click SecureAuth.Agent.Service and click Properties.

  3. Select Details to see the Connector version.

    connector_version.png

Updating the SecureAuth Connector

Note

You do not need to uninstall the SecureAuth Connector before updating,

  1. Open the Identity Platform application.

  2. On the left side of the Identity Platform page, click Data Stores.

    The User Data Stores page opens.

  3. Click the Open Installer instructions link.

    connector_installer_2202.png

    The Connector Installer page opens.

    connector_installer_msi.png
  4. Click the .msi installer link.

    The installer file is downloaded and saved to your machine.

  5. Go to where the installer file is saved.

  6. Right click SecureAuthConnectorSetup.msi and run as Administrator.

    The prompt to update appears.

    connector_update.png
  7. Click Next.

  8. Follow the remaining installation prompts to complete updating the SecureAuth Connector.