SecureAuth Connector troubleshooting
This topic is intended to provide troubleshooting issues with the SecureAuth Connector.
For more information about the latest SecureAuth Connector version, see the SecureAuth compatibility guide.
Prerequisites and dependencies
Identity Platform release 19.07 or later, cloud deployment
As a system administrator tasked with setting up the Identity Platform for your organization, you must have access to the same email used to provision and authenticate your access to the Identity Platform
Access to a local data store server containing your data stores
Recommended installation on a standalone box. At this time, the Connector is not certified for use on the Identity Platform on-premises appliance or a domain controller.
At minimum, the local data store server must have the following system requirements (the same configuration also applies to virtual machines):
Operating Systems
Specifications
Ports to open
Windows Server 2012 R2 (64-bit)
Windows Server 2016 (64-bit)
Windows Server 2019
Internet Explorer 11+ or later
Microsoft .NET Framework 4.7.2 or later
Disk: 200MB
RAM: 4GB
Open port 443 to the data store
Open port
pkc-4nym6.us-east-1.aws.confluent.cloud:9092
and add this to your firewall allow listOpen any other ports to the data stores (for example, port 389 to the Active Directory)
Note
Be sure to install or update Microsoft .NET to 4.7.2 or later, as this requires a system reboot before you can download and install the Connector.
Symptom
Connector is not responding.
Cause
There are some reasons why the Connector might not be responding:
Windows service is not running
There are no data store configurations; the Connector is installed and waiting for more instructions and is not able to do anything but send health checks
Resolution
What you can do:
Restart the SecureAuth Connector Service from the Windows Control Panel
Look at the Connector logs for clues; the Connector log path is C:\ProgramData\SecureAuth Corporation\SecureAuth Connector\logs