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SecureAuth Connector troubleshooting

This topic is intended to provide troubleshooting issues with the SecureAuth Connector.

For more information about the latest SecureAuth Connector version, see the SecureAuth compatibility guide.

Note

At minimum, Identity Platform release 21.04 or later requires SecureAuth Connector version 1.2.4.

Prerequisites and dependencies

  • Identity Platform release 19.07 or later, cloud deployment

  • At this time, the Connector is not certified for use on the Identity Platform on-premises appliance or a domain controller

  • Recommended installation on a standalone box

  • As a system administrator tasked with setting up the Identity Platform for your organization, you must have access to the same email used to provision and authenticate your access to the Identity Platform

  • Be sure to install or update Microsoft .NET to 4.8.1 or later, as this requires a system reboot before you can download and install the Connector

  • Access to a local data store server containing your data stores

  • At minimum, the local data store server must have the following system requirements (the same configuration also applies to virtual machines):

    Supported operating systems
    • Windows Server 2022

    • Windows Server 2019

    • Windows Server 2016 (64-bit)

    • Windows 11

    • Windows 10

    Minimum required specifications
    • Internet Explorer 11+ or later

    • Microsoft .NET Framework 4.8.1 or later

    • Disk: 200MB

    • RAM: 4GB

    Ports to open

    Source

    Destination

    Ports

    Notes

    Connector

    Data store

    (data store specific)

    Common ports:

    AD
    • 389

    • 636 (Secure)

    SQL
    • 1433

    Connector

    pkc-4nym6.us-east-1.aws.confluent.cloud

    9092

    Add this to your firewall allow list.

    Connector

    Allow outbound connection

    443

    Note

    If you have any questions about which ports to open, contact SecureAuth Support.

Symptom

Connector is not responding.

Cause

There are some reasons why the Connector might not be responding:

  • Windows service is not running

  • There are no data store configurations; the Connector is installed and waiting for more instructions and is not able to do anything but send health checks

Resolution

What you can do:

  • Restart the SecureAuth Connector Service from the Windows Control Panel

  • Look at the Connector logs for clues; the Connector log path is C:\ProgramData\SecureAuth Corporation\SecureAuth Connector\logs