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WebAdmin is unavailable

Applies to

SecureAuth IdP code base 5.4.x or greater.

Symptom

User is unable to access the WebAdmin locally from the appliance desktop or via the URL HTTPS://<appliance-fqdn>/secureauth0/secureauth.aspx. The user may receive a "Page Unavailable" or a 404 error.

Discussion

Cause

The most common causes are configuration changes to the local account called "SecureAuth0" or the Application Pool "SecureAuth0Pool". The WebAdmin site (SecureAuth0) uses the SecureAuth0Pool Application pool which uses the local SecureAuth0 account as it's Identity. Changes to either of these elements (manual or Group Policy applied) can cause access issues.

Resolution

1. Verify the local account "SecureAuth0" is a local administrator on the appliance has not been locked or disabled.

Note

The following script should be be executed as an administrator if the appliance is a member of your internal Active Directory Domain. The script can be found in "D:\MFCApp_Bin\Extras\RefreshSecureAuth0.cmd"

2. Execute the SecureAuth refresh script from Start > All Programs > SecureAuth > Refresh_Secureauth0.

  • Attempt to view the WebAdmin by browsing to https://localadmin/secureauth0/localadmin.aspx on the appliance browser. If you are able to access the WebAdmin the problem is solved. If not, continue to step 3.

3. Open IIS Manager and review the Applications Pools.

  • Expand Application Pools. The Application Pool SecureAuth0Pool should be started and the "Identity" should read "SecureAuth0". (See Image 1a below).

  • If the Application pools is "Stopped" attempt to start it by highlighting SecureAuth0Pool and selecting "Start" from the Actions menu. Attempt to view the WebAdmin by browsing to https://localadmin/secureauth0/localadmin.aspx on the appliance browser. If WebAdmin opens you have corrected the issue. If WebAdmin does not open, check the Application pool again. If it has stopped again go to the next option.

  • If the .Net Framework, Managed Pipeline or Identity are different than shown in image 1a, change the settings by selecting "Advanced Settings" and changing the settings as required. (See Image 1b)

  • Highlight SecureAuth0Pool again and verify "1" application is associated with it. If the applications listed is "0", Select the SecureAuth0 Virtual Directory under the Default Web Site and select "Advanced Settings" on the Actions menu. Change the Application Pool to "SecureAuth0Pool" (See Image 1c). Attempt to view the WebAdmin by browsing to https://localadmin/secureauth0/localadmin.aspx on the appliance browser. If WebAdmin opens you have corrected the issue.

4. If you have completed these steps and the website is still unavailable, or you are running on SecureAuth Code version 5.3.x or lower, contact support@secureauth.com for assistance.

Image 1a
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Image 1b
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Image 1c
image2012-6-5_10_39_54.png