Error: The date/time on your computer is inaccurate. Please check and adjust the date/time before proceeding.
Issue
End-users receive the following error when landing on the SecureAuth IdP login page
Warning
The date/time on your computer is inaccurate. Please check and adjust the date/time before proceeding.
Applies to
SecureAuth IdP enrollment and/or validation of Java Certificates for 2-Factor Authentication realms, with the following configurations in the Workflow tab:
1. In the Product Configuration section, Certification Enrollment and Validation selected from the Integrated Method dropdown
2. Java Applet selected from the Client Side Control dropdown
3. In the Workflow section, False selected from the Allow Fall Back dropdown
Cause
During the authentication process, the SecureAuth IdP appliance utilizes the time and date (along with other factors) as parameters for the validation process. The underlying method for certificate validation is sensitive to time discrepancies and will fail if the appliance clock is five or more minutes off. If the time and/or date on the client machine is inaccurate, then this error occurs.
Resolution
End-users must correct the time and/or date on the client machine.
Additional Information
The content of this error can be edited in the Verbiage Editor section in the SecureAuth IdP Web Admin
1. In the Web Admin, enter the Overview tab and scroll down to Advanced Settings
2. Click Content and Localization and locate the Verbiage Editor section on the new page
3. Scroll down to or search for useridview_inaccuratedatetime and make any necessary edits
4. Click Save