Issue with a Microsoft Office 365 application which uses WS-Trust
Symptom
An issue exists for the Microsoft Office 365 application which uses WS-Trust. One of the symptoms is that the screen is blank when loading the application.
Cause
There could be other causes not related to SecureAuth, but to see if this is a code issue, paste the following URL in the user's browser:
https:/<secureauthFQDN>/sarealm/wstrust.svc/mixed/username
If you receive the .NET error page stating "The HTTPGetENabled property of SecriceMetadataBehavior is set to true and the HttpGetUrl property is a relative address..." the problem is code related and a DLL will need to be Updated on the SecureAuth Appliance.
Resolution
1. Download the file from the following link to the SecureAuth Appliance: SecureAuth.IdentityModel.WSFederation
2. Rename the file extension to from .zzz to .dll
3. Place the file (replace the existing file) in the /Bin folder of the realm which provides the WS-Federation/WS-Trust authentication for your organization
4. When finished with the file copy, initiate a "IISReset" on the SecureAuth appliance and test again
If this does not resolve the issue, contact us at support@SecureAuth.com